Getty Images API Forums

Authentication (OAuth, CreateSession, Tokens)

RSS Feed

/oauth2/token - Client Credentials - Returns Null Value

  1. I'm having some problems to request the token for authentication. I have two API Keys.

    I'm doing the requests via C#, the request with the first key returns:

    { "access_token": null, "token_type": "Bearer", "expires_in": "0", "refresh_token": null }

    Using the same key in the Swagger UI, to do the same request, return the same null value:

    { "access_token": null, "token_type": "Bearer", "expires_in": "0", "refresh_token": null }

    Using the second key, i can get the token, but when i call the download API, i get this return:

    "NoDownloadAuthorization - No download authorization were found for asset . Perhaps the user has no active product types."

    Is there any additional configuration that I can do?

    Message edited by rio2016_connect 2 months ago

  2. Getty Images Matt1 year ago

    Hi... your test account had expired. I've turned it back on, but you'll want to reach out to your Getty Images rep, Eugene, to discuss options for continued access.


  3. Nishesh2 months ago

    "Authorization: Bearer <your-token>". The TOKEN is Secret "xyz". xyx is my token or not and one more thing the Secret in the Connect Embed: 5 QPS or in Getty Test: Sandbox... I am getting in responce

    { "pragma": "no-cache", "date": "Mon, 22 May 2017 10:22:18 GMT", "www-authenticate": "Bearer realm=\"Download\",error=\"invalid_token\",error_description=\"The access token is malformed\"", "server": "Mashery Proxy", "x-mashery-responder": "", "x-powered-by": "ASP.NET, ARR/3.0, ASP.NET", "access-control-max-age": "3600", "access-control-allow-methods": "OPTIONS, POST, GET, PUT, DELETE", "cache-control": "no-cache,no-cache", "gi-coordination-id": "auto_-z8koyz2vvEWms2A-UepRBw", "connection": "keep-alive", "x-robots-tag": "noindex", "access-control-allow-headers": "Origin, Accept, Content-Type, Accept-Language, Api-Key, Authorization", "content-length": "0", "expires": "-1", "content-type": null }

  4. Paul Krug2 months ago

    Could you please post your request? Don't include your key/secret information though.

[ Page 1 of 1 ]