Getty Images API Forums

Download

RSS Feed

Unauthorized

    • Rob P
    • Topic created 3 weeks ago

    I log in using the client credentials method, perform a search, which results in 2 images I can see and 48 that return a 403 error code, assuming this is Sandbox specific, then when I issue a download get an error returned:

    {"ErrorCode":"Unauthorized","ErrorMessage":"Your access token does not authorize access to this resource."}

    https://api.gettyimages.com/v3/downloads/images/182175109?auto_download=false&product_type=creditpack&file_type=jpg&height=2912

    The development account is NOT under this username, but I needed to create this account to make certain it was delivered to my email address. Any help is appreciated, particularly coming into he July 4th celebration.

    Message edited by Rob P 6 days ago

  1. Mark Pitman3 weeks ago

    Sandbox keys are limited in what they can be used for. You won't be able to download actual images and you definitely cannot specify that you want to download using credits. Can you give us some more info on what it is you want to do with images you search for? I can also put you in touch with someone from sales if you are interested in using images in a project you are working on.

  2. Rob P3 weeks ago

    I had been working with Matt D. (the account is voodoo.com_connect), though his auto-reply said he was away until Thursday and I'm Leaving for 10 days on Friday and this project I began in December, and have shifted around several times due to more pressing projects.

    We have several thousand credits from iStock and when this project begand on Getty's end, the API did not support what we needed, basically to search for images, download to our system, then display them on our sites.

    The Docs state that product type may be of type creditpack, I tried them all just in case, and none have worked, all returning the same error.

    In order to build a working system, it would be beneficial, actually crucial, to be able to download the image, even just a placeholder, so that I know it is working. If the API is not providing me anything, how will I know it's working?

  3. Mark Pitman3 weeks ago

    OK, thanks for the extra info. I think the problem is that you should be using Resource Owner to get your token. That will require your iStock account credentials. Using the token you receive from that call, you should be able to search and then download using your iStock credits.

  4. Rob P6 days ago

    So, I've gotten everything else working with a minor exception, well not minor really. Working under the assumption that I was not seeing images because of the sandbox keys, I was able to view and download images I assumed were intended for testing without issue. I contacted Matt and received production keys, added these to our code, and tested. Almost everything worked, except viewing images from the provided URL; they result in a 403 Forbidden error.

    "403 - Forbidden: Access is denied. You do not have permission to view this directory or page using the credentials that you supplied."

    Contacted Matt and he assumed he needed to whitelist our URLs, which he did and then I waited a few hours to test. No change. That was about 13 days ago, I was leaving on a family vacation.

    Having returned, nothing has changed and I have been unable to reach Matt.

    exampleGetty Image URL: https://media.istockphoto.com/photos/person-opening-can-of-carbonated-beverage-picture-id157165635?s=170x170

    The docs say a GET should be all that is necessary, what crucial bit am I missing here?

  5. Getty Images Matt6 days ago

    Hi Rob, sorry for not getting back to you sooner. This likely means that your requesting domain is different from what we have on record. But I'll take this up with you over email so we can sort it out.

[ Page 1 of 1 ]