Getty Images API Forums

Authentication (OAuth, CreateSession, Tokens)

RSS Feed

Connection Failure. Status code unavailable

  1. I am seeing below error from last two days I/O Exception: hostname in certificate didn't match: <api.gettyimages.com> != <.execute-api.us-west-2.amazonaws.com> OR <.execute-api.us-west-2.amazonaws.com>

    Message edited by gothamcity_connect 6 days ago

  2. Getty Images Matt1 week ago

    You'll need to ensure that your client is using SNI.

  3. gothamcity_connect1 week ago

    But is that any thing changed from getty API, it suddenly stopped working from yesterday?

    Can you please provide if any changes in API calls. we are using below API url: https://api.gettyimages.com/oauth2/token/

  4. Mark Pitman1 week ago

    Yes, there was a change in our infrastructure recently that requires clients to support SNI (Server Name Indication). Most languages and frameworks have supported SNI since about 2011. If you are using an old version of Java (Java 6?) or PHP (older than 5.3), etc., you'll need to update to a newer version.

  5. gothamcity_connect6 days ago

    Same code and credentials are working from my dev site (deuce.gothamcityonline.com). and not working form Live site. ace.gothamcityonline.com

    Do you have any idea, both the sites are using same OS and java versions.We are using ColdFusion 10 version.

  6. Chris Simmons6 days ago

    Hello gothamcity_connect,

    (I am assuming you are referring to the same "hostname in certificate didn't match" message as previously mentioned.)

    Unfortunately we don't have guidance on specific client technology. As Mark mentioned, we have seen the issue with SNI come up with old versions of Java (specifically 6 or older). It sounds like Java plays some part here in your ColdFusion stack.

    I would recommend research into ensuring that SNI is supported and enabled at the point in your stack at which the actual HTTP call is made to the Getty API.

[ Page 1 of 1 ]